.

Monday, July 19, 2010

Install Facebook API plugins for Rails

There are currently two public, open source options for integrating Rails projects with the Facebook platform: Facebooker (created by Chad Fowler and maintained by Mike Mangino), and RFacebook (originally led by Matt Pizzimenti). If all you need is simple, hand-rolled integration with just one or two Facebook API features using Ruby, take a look at this example from github.

While the rest of this page contains information about RFacebook, please be aware that RFacebook is no longer being maintained. There is a newer branch available that is not maintained by the original author.

There is this Facebooker Tutorial or this older Facebooker Tutorial. Please use the installation instructions from here, as the project has been moved to Github from RubyForge. The mailing list is a Google Group.

There is also a book that serves as an introduction to Facebook using Facebooker. It is available from the Pragmatic Programmers. There is also a two part screencast .

On the commandline, install the latest version (>= 0.9.8) of the gem:

gem install rfacebook

If you are using Rails, then you also want to install the plugin:

script/plugin install http://rfacebook.rubyforge.org/svn/trunk/rfacebook/plugins/rfacebook

svn://rubyforge.org/var/svn/rfacebook/plugins/rfacebook has been deprecated

svn://rubyforge.org/var/svn/rfacebook/plugins/rfacebook_on_rails has been deprecated


1 comments:

itstaff said...

oh my god. Thanks byungjin so much!

Post a Comment

Facebook Twitter Delicious Digg More

 
Design by Free WordPress Themes | Bloggerized by Lasantha - Premium Blogger Themes | Macys Printable Coupons